Smite PS4 Patching Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This issue has been resolved.
#SMITE #PS4
Posted over 1 year ago. May 16, 2016 - 21:40 EDT
Investigating
We are currently aware of issues effecting users trying to update #Smite on #PS4.
We are working to resolve these issues.
Posted over 1 year ago. May 16, 2016 - 18:45 EDT