Live Services Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
All games are back online. We are keeping an eye on all games while we continue to implement the fix.
Posted May 03, 2020 - 10:35 EDT
Monitoring
All games are back online. We are keeping an eye on all games while we continue to implement the fix.
Posted May 03, 2020 - 10:34 EDT
Update
Paladins is back online. We are keeping an eye on Paladins and Smite while we continue to implement the fix.
Posted May 03, 2020 - 10:24 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 03, 2020 - 09:59 EDT
Update
Smite is back online. We are still working on the other games and keeping an eye on Smite.
Posted May 03, 2020 - 09:51 EDT
Update
We are continuing on investigating the issue, thank you for your patience.
Posted May 03, 2020 - 08:58 EDT
Investigating
We are currently investigating this issue that is impacting all games.
Posted May 03, 2020 - 08:05 EDT
This incident affected: SMITE (SMITE PC, SMITE PS4, SMITE Xbox, SMITE Switch), Paladins (Paladins PC, Paladins PS4, Paladins Xbox, Paladins Switch), and Realm Royale Reforged (Realm Royale PC, Realm Royale PS4, Realm Royale Xbox, Realm Royale Switch).