Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Issue with #Smite #PC has been resolved
Posted 2 months ago. Jun 16, 2017 - 13:02 EDT
Identified
We have identified an issue with #Smite #PC and are actively working to resolve.
Posted 2 months ago. Jun 16, 2017 - 12:49 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 2 months ago. Jun 16, 2017 - 12:32 EDT
This incident affected: Smite PC - North America / Europe.