Smite PC stopping logins for a short while
Incident Report for Hi-Rez Studios, Inc
Resolved
Smite PC logins are now functioning normally.
#SMITE
Posted over 1 year ago. Mar 01, 2016 - 13:55 EST
Investigating
Sorry for the inconvenience.
#SMITE
Posted over 1 year ago. Mar 01, 2016 - 13:48 EST