Smite PS4 Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This incident has been resolved. #SmitePS4
Posted about 2 months ago. Feb 04, 2017 - 08:14 EDT
Investigating
Automated services have detected a possible problem with #SMITE PS4. We are investigating.
Posted about 2 months ago. Feb 04, 2017 - 05:57 EDT
This incident affected: Smite PS4 - North America / Europe.