Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Smite XBOX incident has been resolved. #SmiteXBOX
Posted 6 months ago. May 11, 2017 - 11:55 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted 6 months ago. May 11, 2017 - 10:57 EDT
This incident affected: Smite Xbox - North America / Europe.