Smite Paladins and Realm Royale Emergency restarts
Incident Report for Hi-Rez Studios, Inc
Resolved
#RealmRoyale restart has been completed
Posted Dec 29, 2020 - 15:33 EST
Update
Restart of #Smite has been completed
Posted Dec 29, 2020 - 15:23 EST
Update
Restart for #Paladins has been completed
Posted Dec 29, 2020 - 15:23 EST
Update
We are continuing to work on a fix for this issue.
Posted Dec 29, 2020 - 15:21 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 29, 2020 - 15:17 EST
Update
We are continuing to investigate this issue.
Posted Dec 29, 2020 - 15:16 EST
Investigating
#Smite #Paladins and #Realm Royale will all need to be restarted immediately. All games will be back up as soon as possible
Posted Dec 29, 2020 - 15:07 EST
This incident affected: SMITE (SMITE PC, SMITE PS4, SMITE Xbox, SMITE Switch, SMITE Epic), Paladins (Paladins PC, Paladins PS4, Paladins Xbox, Paladins Switch, Paladins Epic), and Realm Royale Reforged (Realm Royale PC, Realm Royale PS4, Realm Royale Xbox, Realm Royale Switch).