Smite Xbox Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 10 days ago. Aug 11, 2018 - 22:33 EDT
Monitoring
Restart is complete. We will continue to monitor for any further issues.
Posted 10 days ago. Aug 11, 2018 - 22:03 EDT
Identified
We are performing an emergency restart for #Smite #Xbox. The game will be back soon.
Posted 10 days ago. Aug 11, 2018 - 21:51 EDT
This incident affected: Smite (Smite Xbox).