Hirez Games Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This problem is currently resolved
Posted 3 months ago. Mar 10, 2017 - 08:43 EST
Investigating
Automated services have detected a possible patcher issue that may impact multiple games. We are investigating. #SMITE #Paladins
Posted 3 months ago. Mar 10, 2017 - 08:05 EST