Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Issues with Smite PC have been resolved.
Posted 4 months ago. Apr 17, 2017 - 16:20 EDT
Monitoring
We are currently monitoring issues with Smite PC. #SMITE #PC
Posted 4 months ago. Apr 17, 2017 - 16:18 EDT
Update
Investigating: We are currently investigating this Smite PC issue. #SmitePC
Posted 4 months ago. Apr 17, 2017 - 16:12 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 4 months ago. Apr 17, 2017 - 16:08 EDT
This incident affected: Smite PC - North America / Europe.