Paladins PS4 Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 2 months ago. Jul 13, 2018 - 13:03 EDT
Monitoring
The Paladins PS4 restart has been completed and logins have been re-enabled.
Posted 2 months ago. Jul 13, 2018 - 10:52 EDT
Investigating
We are performing an emergency restart on #Paladins #PS4
Posted 2 months ago. Jul 13, 2018 - 10:44 EDT
This incident affected: Paladins (Paladins PS4).