Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The emergency restart for #Smite on #PC has been completed.
Posted 7 months ago. Mar 24, 2017 - 21:19 EDT
Identified
We will be performing an emergency restart of #Smite on #PC
We apologize for the inconvenience.
Posted 7 months ago. Mar 24, 2017 - 21:04 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 7 months ago. Mar 24, 2017 - 20:59 EDT
This incident affected: Smite PC - North America / Europe.