Hirez Games possible issue
Incident Report for Hi-Rez Studios, Inc
Resolved
We had a brief problem with a data center that affected all games.##SMITE #Tribes #Paladins
Posted almost 2 years ago. Mar 10, 2016 - 03:52 EST
Investigating
Automated services have detected a possible problem our Atlanta servers and may affect all games. #SMITE #Tribes #Paladins. We are investigating.
Posted almost 2 years ago. Mar 10, 2016 - 03:35 EST