Hirez Games possible issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The connectivity issue has subsided and logins are returning to normal for all products.
Posted 5 months ago. Oct 19, 2016 - 06:45 EDT
Monitoring
We experienced a connectivity issue that briefly impacted all live environments; we are slowly recovering and continuing to monitor the situation.
Posted 5 months ago. Oct 19, 2016 - 06:29 EDT
Investigating
Automated services have detected a possible problem our Atlanta servers and may affect all games. #SMITE #Tribes #Paladins. We are investigating.
Posted 5 months ago. Oct 19, 2016 - 06:04 EDT