Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 8 months ago. Aug 14, 2016 - 16:37 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted 8 months ago. Aug 14, 2016 - 14:59 EDT