Smite Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted May 03, 2020 - 04:30 EDT
Monitoring
The game is back up and we're keeping an eye on things.
Posted May 03, 2020 - 03:52 EDT
Update
We are continuing to investigate this issue.
Posted May 03, 2020 - 02:51 EDT
Investigating
We are performing another emergency restart on Smite.
Posted May 03, 2020 - 02:51 EDT
Monitoring
The restart is now complete. We will be monitoring the results.
Posted May 02, 2020 - 22:50 EDT
Investigating
We will be performing an emergency restart of Smite. The game will be back shortly
Posted May 02, 2020 - 22:33 EDT
This incident affected: SMITE (SMITE PC, SMITE PS4, SMITE Xbox, SMITE Switch).