All PC games - difficulty with Logins and Authentication
Incident Report for Hi-Rez Studios, Inc
Resolved
Issue with Logins and Authentication for #Smite PC, #Paladins PC, and #Tribes PC has been resolved.
Posted 10 months ago. Sep 19, 2016 - 17:07 EDT
Identified
We are aware of an issue currently impacting Logins and Authentication for #Smite PC, #Paladins PC, and #Tribes PC; a fix has been identified and we are working towards a resolution.
Posted 10 months ago. Sep 19, 2016 - 15:54 EDT