Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Paladins incident has been resolved. #paladins
Posted about 1 year ago. Dec 11, 2016 - 16:28 EST
Update
We are limiting logins for a short time and restarting a component in the game#paladins
Posted about 1 year ago. Dec 11, 2016 - 16:20 EST
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted about 1 year ago. Dec 11, 2016 - 16:14 EST