Smite PC/XBOX Disconnect issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted almost 2 years ago. Oct 01, 2015 - 13:01 EDT
Investigating
We are investigasting
Posted almost 2 years ago. Oct 01, 2015 - 12:27 EDT