Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The issue with #Smite #XBox has been resolved and log ins have resumed.
Posted Jul 18, 2017 - 15:26 EDT
Identified
We have identified an issue with #Smite #XBox and are working on bringing services back up
Posted Jul 18, 2017 - 15:13 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted Jul 18, 2017 - 15:06 EDT