Smite XBOX purchases having issues
Incident Report for Hi-Rez Studios, Inc
Resolved
XBox Live has resolved purchasing issues that were impacting #SMITE on the XBox One.
Posted almost 2 years ago. Feb 23, 2016 - 14:43 EST
Identified
Some #Smite xbox users having problems with purchasing. Appears to be Microsoft XBOX Live issue.
Posted almost 2 years ago. Feb 23, 2016 - 09:33 EST