Paladins Login Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 28 days ago. Sep 18, 2019 - 03:41 EDT
Update
We are continuing to investigate this issue.
Posted 28 days ago. Sep 17, 2019 - 22:43 EDT
Investigating
We are currently investigating an issue some players are having with logging into Paladins
Posted 28 days ago. Sep 17, 2019 - 22:14 EDT
This incident affected: Paladins (Paladins PC, Paladins PS4, Paladins Xbox, Paladins Switch).