Smite PS4 Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Smite PS4 incident has been resolved#smite
Posted 12 months ago. Aug 20, 2016 - 12:23 EDT
Investigating
Automated services have detected a possible problem with #SMITE PS4. We are investigating.
Posted 12 months ago. Aug 20, 2016 - 11:41 EDT