Hirez Games possible issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Experienced brief period of player loss due to datacenter maintenance; we are recovering.
Posted 12 months ago. Aug 11, 2016 - 05:44 EDT
Investigating
Automated services have detected a possible problem our Atlanta servers and may affect all games. #SMITE #Tribes #Paladins. We are investigating.
Posted 12 months ago. Aug 11, 2016 - 05:30 EDT