Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The issues with #Paladins PC has been resolved.
Posted May 28, 2017 - 13:00 EDT
Monitoring
We have corrected issues with #Paladins PC and are continuing to monitor; logins have resumed.
Posted May 28, 2017 - 12:41 EDT
Identified
We have identified issues with #Paladins PC and are working to mitigate; will be pausing logins briefly.
Posted May 28, 2017 - 12:28 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted May 28, 2017 - 12:23 EDT
This incident affected: Paladins (Paladins PC).