Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This Paladins PC incident has been resolved.
Posted 3 months ago. Apr 05, 2017 - 12:06 EDT
Update
We are currently looking into issues with Paladins PC
Posted 3 months ago. Apr 05, 2017 - 11:53 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 3 months ago. Apr 05, 2017 - 11:33 EDT
This incident affected: Paladins PC.