Smite Xbox - Hi-Rez Games Maintenance
Incident Report for Hi-Rez Studios, Inc
Resolved
This #Smite #Xbox maintenance has been completed.
Posted Jul 19, 2018 - 13:34 EDT
Identified
All Hi-Rez Games are going down for maintenance on July 19, 2018 with Limited access starting at 09:30 UTC. This maintenance will impact all Hi-Rez products including; #Tribes. #Smite, #Paladins, #HotG, #RealmRoyale, as well as Web and API services.
Posted Jul 19, 2018 - 11:42 EDT
This incident affected: SMITE (SMITE Xbox).