Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 4 months ago. Jun 16, 2017 - 11:52 EDT
Monitoring
We have re-enabled logins and are continuing to monitor #Paladins #PC
Posted 4 months ago. Jun 16, 2017 - 11:06 EDT
Update
We are investigating an issue with #Paladins #PC
Posted 4 months ago. Jun 16, 2017 - 10:51 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 4 months ago. Jun 16, 2017 - 10:49 EDT