Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Paladins incident has been resolved. #paladins
Posted 8 months ago. Oct 15, 2016 - 10:54 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 8 months ago. Oct 15, 2016 - 10:45 EDT