Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Network oddities in EU caused some failed match starts; has been resolved.
Posted almost 2 years ago. Mar 11, 2016 - 13:29 EST
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted almost 2 years ago. Mar 11, 2016 - 13:22 EST